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CHAPTER 1 
TDP START/STOP 

TDP Start/Stop (TdpStart) is graphical user interface (GUI) that manages the starting and 
stopping of data acquisition in an Acroamatics PCI Telemetry Data Processor (TDP). One or 
more acquisition devices can be started synchronously on a PCM frame boundary, while others 
can be started and stopped on the fly. TdpStart supports hard disk recording and network 
multicasting for the Acroamatics 6011605 Programmable Data Stream Processor card, and one 
or more 6011602 PCM Decommutator cards. TdpStart can also be used on computers with 
installed Acroamatics 6011626P PCI Multi-Channel Frame Synchronizer cards. TdpStart can 
start and stop data recording operations on the 1626P cards. 

Main Window 
The main window contains a row for each card detected. Each Properties button opens a dialog 
to configure the card's settings like the recording file and multicast address. To control one or 
more cards, place a checkmark next to each card of interest, then use the Start and Stop buttons. 
The main features are summarized in the following figure. 

 
Figure 1-1: Main Screen Callouts 

Hover for tooltip to 
summarize properties. 

Right-click in 
card area for 
context menu.

Checkmark 
selects card for 
next Start/Stop 
button press. 

Opens dialog for 
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Start/Stop selected 
cards and/or TDP. 
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selected, only TDP 
is affected. Hover 
for tooltip. 

Card Recording 
Status. 

TDP Run Status. Must 
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Icon is "!" when 
there are messages. 

Double-click to view frame 
sync status, IRIG time, TDP 
inputs and outputs. 
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Automatic Last Configuration Recall 
At startup, TdpStart automatically recalls its last window size and location. If your system has 
too many cards to fit in the default window size, resize the window. The new window size will 
be used the next time you run the program.  

TdpStart also recalls its last setup, including the properties of each card, main window card 
selections, and options set under the Options menu. To save setups in addition to the default last-
used setup, use the Save As and Open commands in the File menu.  

Start/Stop, TDP Run, and PCM Frame Boundaries 
TDP Run is a global signal within the TDP that controls when PCMD cards start producing 
decommutated data. Upon receiving TDP Run, a PCMD begins to output data at its next frame 
boundary. If a recording is started at the same time as TDP Run, it will begin at a PCM frame 
boundary. If it is started after TDP Run, the recording will start at an arbitrary word inside the 
PCM frame. TdpStart handles TDP Run automatically, but you can influence it using the "Sync 
1st Recorders to Frame Boundary" item under the Options menu, as explained in the following 
paragraphs. 

When the "Sync 1st Recorders to Frame Boundary" item under the Options menu is checked, the 
first cards started will always be synchronized to a frame boundary. If the TDP is already 
running when these cards are started, TdpStart momentarily stops the TDP, starts the recorders 
for the selected cards, and restarts the TDP. Any cards started later cannot be synchronized with 
TDP Run, because to do so would require momentarily stopping the data flow to the cards 
already recording. Therefore, cards started later do not start on a frame boundary. When the last 
card is stopped, TdpStart will restore the TDP to the run state it had prior to the start of the first 
recordings. When no cards are running or selected, the Start and Stop buttons can be used to 
control just TDP Run. 

When the "Sync 1st Recorders to Frame Boundary" item under the Options menu is unchecked, 
TdpStart does not guarantee that the 1st recordings start at a frame boundary. This mode can be 
useful when the TDP data is sent to destinations that cannot tolerate a momentary interruption in 
the data flow, and it is not important that recorded data start at a frame boundary. If the TDP is 
idle when the 1st cards are started, TdpStart starts the recorders for the selected cards, and then 
starts the TDP. In this case, the 1st recordings will start at a frame boundary because they were 
started at the same time as TDP Run. If the TDP is already running when the 1st cards are 
started, TdpStart will start the recorders for the selected cards without affecting TDP Run. In this 
case, the recordings will start at an arbitrary word within their respective PCM frames, but data 
flow to other devices is not interrupted. Any recordings started after the first recordings always 
start at an arbitrary word within the PCM frame. When the last card is stopped, TdpStart will 
restore TDP Run to the state it had prior to the start of the first recordings. When no cards are 
running or selected, the Start and Stop buttons can be used to control just TDP Run. 

File Menu 
Use the File menu to save and retrieve setups. Setups are saved with the ".tds" extension. The 
setup file contains a description of how each card was configured, and whether or not it was 
selected for start/stop. 

View Menu 
This menu allows you to open other windows related to TdpStart. Select TDP Status to run the 
TDP Status program, which shows frame sync status, IRIG time, and TDP inputs and outputs. 
You can also run TDP Status by double-clicking its icon on the status bar. Select Start/Stop 
Error Console to open the error console window. This window displays all of TdpStart's error 
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messages. Normally, this window is empty. The Error Console window can also be opened by 
double-clicking its icon on the status bar. The icon is an "i" if are no error messages, or an "!" if 
there are messages. 

Options Menu 
This menu contains the "Sync 1st Recorders to Frame Boundary" item, which influences how 
TdpStart handles the TDP Run signal. See the section "Start/Stop, TDP Run, and PCM Frame 
Boundaries" for a complete discussion. 

PDSP Properties 
This dialog configures a PDSP card for recording. If a PDSP card is installed, open this dialog 
by pressing its Properties button on the main window. The main features are summarized in the 
following figure. 

 

 
 

Figure 1-2: PDSP Properties 

Record Destination 
The card may be installed either in the local computer, or a computer on the local area network 
(LAN). The recording can be made to a file, and/or a network destination.  

Server Host 
To record using a card installed in the local computer, the TDP software should be installed 
using the standard PCI Telemetry Operations Installation, Acroamatics part number 6065112. 
No special tdpc.cfg setup is required. 
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To record using a card in a remote computer, you must install on the local computer 
Acroamatics part number 6065045, Remote Display and Operation. There are two parameters 
that must be set in the local computer's tdpc.cfg file to enable remote control. These may be set 
during the Remote Display and Operation installation, or after installation by editing the file 
C:\tdpsys\tdpc.cfg. For example, if the card is installed in a remote computer named TDP01, the 
local computer must have the following entries in the C:\tdpsys\tdpc.cfg file: 

ACRO_RECORD_SERVER_HOST=TDP01 
ACRO_TM_SERVER=TDP01 

You must restart TdpStart for changes to take affect.  

File 
To record to file, select Enabled from the dropdown list and enter the filename in the textbox. If 
the Server Host is <Local>, you can use the ... button to browse for the file destination. 

Data File Renaming 
To protect against the possibility of overwriting a data file, check the box titled “Automatic Data 
File Renaming”. When this mode is selected and you have chosen a file name that names an 
already existing file, the name you have chosen will be modified so that it does not match the 
name of an existing file. This is done by adding a three digit suffix to the file base name. For 
example if the file name is C:\FlightTest it could be renamed C:\FlightTest001. If the file name 
is c:\Flight.Tst it could be renamed C:\Flight001.Tst. 

If this mode is not selected the new data file will not be renamed and any preexisting file of the 
same name will be overwritten. 

Network 
To send the data to a multicast or point-to-point UDP address, choose Enabled from the 
dropdown list, and fill in the Address and Port text boxes. Valid multicast addresses have a value 
between 224 and 239 in the 1st octet. Other addresses will select point-to-point UDP. 

PDSP Stream Output Device 
To select one of four PDSP stream output devices use the “Output Stream Device” combobox to 
select DV1, DV2, DV3, or DV4. 

Record Length 
Use this control to set the length of the DMA transfers out of the PDSP device. Your entry here 
is the number of 32-bit words for the transfers. The data recorder operates most efficiently at 
high data rates using large record lengths. Using smaller record lengths is more suitable for slow 
rate data. The largest number allowed for record length is 65536, the smallest 128. Also, when 
recording data to a file on your hard disk you will see better performance when the record length 
selection is an integer multiple of 128 32-bit words (512 bytes). 

Data Buffer Pre-fill 
When the data buffer pre-fill mode is enabled the record server will pre-fill each data buffer with 
a fill pattern before transferring data from the PDSP card into the data buffers. This makes it 
possible for the data record server to recognize the boundary between fresh data and stale data in 
the final data buffer processed during a data record operation. When this mode is enabled the 
record server will write out to disk any fresh data from a partially filled final data buffer. By 
default, this mode is not selected. When this mode is not selected data from partially filled final 



Acroamatics, Inc. DN 6000402 

 1-5

data buffers is not written out. Since this mode causes delays in the record server data processing 
while it pre-fills data buffers, the use of this mode is advisable only when your data rate is low 
enough to allow its use without data overflow. If this mode is used with data rates that are too 
high, data overflow and loss of data could occur. The rate at which data overflow can occur 
using this mode will vary from machine to machine, and depends on factors such as CPU speed, 
disk speed, available memory and other processing underway on the computer. Another thing to 
consider when using the “Data Buffer Pre-fill” option is the choice of record length. To 
minimize the chance for data overflow use larger record lengths with the “Data Buffer Pre-fill” 
mode option. 

PCMD Properties 
This dialog configures a PCMD card for recording. For any PCMD card installed, open this 
dialog by pressing its Properties button on the main window. The main features are summarized 
in the following figure. 

 
Figure 1-3: PCMD Properties 

Record Destination 
This setup is exactly the same as for the PDSP. See the Record Destination section and its 
subsections under PDSP Properties for a description. 

Output Time Word 
When a time card is installed, time words can be inserted into the data stream. A time word with 
ID 0x1FFE is generated once per second, and 0x1FFF once per millisecond. The format of the 
time words is described in DN6000337 in the section Data Format Control Register. 
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Output Quality Word 
The Quality Word is a status word inserted in the data stream after the mainframe sync. It has ID 
0x1FE0. Use this checkbox to enable Quality Word insertion. The format of the Quality Word is 
described in the Quality Word section of DN6000337. 

Record Length 
Use this control to set the length of the DMA transfers out of the PCMD device. Your entry here 
is the number of 32-bit words for the transfers. The data recorder operates most efficiently at 
high data rates using large record lengths. Using smaller record lengths is more suitable for slow 
rate data. The largest number allowed for record length is 65536, the smallest 128. Also, when 
recording data to a file on your hard disk you will see better performance when the record length 
selection is an integer multiple of 128 32-bit words (512 bytes). 

Data Buffer Pre-fill 
When the data buffer pre-fill mode is enabled the record server will pre-fill each data buffer with 
a fill pattern before transferring data from the PCMD card into the data buffers. This makes it 
possible for the data record server to recognize the boundary between fresh data and stale data in 
the final data buffer processed during a data record operation. When this mode is enabled the 
record server will write out to disk any fresh data from a partially filled final data buffer. By 
default, this mode is not selected. When this mode is not selected data from partially filled final 
data buffers is not written out. Since this mode causes delays in the record server data processing 
while it pre-fills data buffers, the use of this mode is advisable only when your data rate is low 
enough to allow its use without data overflow. If this mode is used with data rates that are too 
high, data overflow and loss of data could occur. The rate at which data overflow can occur 
using this mode will vary from machine to machine, and depends on factors such as CPU speed, 
disk speed, available memory and other processing underway on the computer. Another thing to 
consider when using the “Data Buffer Pre-fill” option is the choice of record length. To 
minimize the chance for data overflow use larger record lengths with the “Data Buffer Pre-fill” 
mode option. 
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MCFS Properties 
This dialog configures a MCFS (Model 1626P PCI Multi-Channel Frame Synchronizer) card for 
recording. If a MCFS card is installed, open this dialog by pressing its Properties button on the 
main window. The main features are summarized in the following figure. 

 
Figure 1-4: MCFS Properties 
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File 
To record to file, select Enabled from the dropdown list and enter the filename in the textbox. If 
the Server Host is <Local>, you can use the ... button to browse for the file destination. 

Data File Renaming 
To protect against the possibility of overwriting a data file, check the box titled “Automatic Data 
File Renaming”. When this mode is selected and you have chosen a file name that names an 
already existing file, the name you have chosen will be modified so that it does not match the 
name of an existing file. This is done by adding a three digit suffix to the file base name. For 
example if the file name is C:\FlightTest it could be renamed C:\FlightTest001. If the file name 
is c:\Flight.Tst it could be renamed C:\Flight001.Tst. 

If this mode is not selected the new data file will not be renamed and any preexisting file of the 
same name will be overwritten. 

Network 
To send the data to a multicast or point-to-point UDP address, choose Enabled from the 
dropdown list, and fill in the Address and Port text boxes. Valid multicast addresses have a value 
between 224 and 239 in the 1st octet. Other addresses will select point-to-point UDP. 

Time and Status 
The 1626P card can add a 64-bit time word the each frame of data on the output. Select this 
option by setting the check for “Output Time Word”. The 1626P can also add a 32-bit status 
word to each frame of data. The status includes 16-bits of frame synchronizer status and a 16 bit 
frame counter. Select this option by setting the check for “Output Status Word”. 

Record Length 
You can set the record length for data transfers out of the 1626P channel by using the “Record 
Length” edit control. This number specifies a count of 16-bit words. You must enter an even 
number. The maximum allowed is 131072. 
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